Yalu Jailbreak will be Updated for iPhone 7 and iPhone 7 plus

Hacker and developer Luca Todesco has tweeted that he will update Yalu 10.1.1 Jailbreak for iPhone 7/7 plus.

iphone-7 yalu1011

He clarified on Twitter that an updated version is in the offing.

As of now, iPhone 7 and iPhone 7 plus are compatible with Yalu jailbreak on iOS 10.1/10.1.1.

To clear it up: Yalu1011 for iPhone 7 will be updated at some point. Just not a priority right now. Got stuff to do.

A lot of users want a jailbreak for iPhone 7/7+ running iOS 10.2. However, this is not possible due to advanced hardware level security used by Apple. Here is the complete explanation of why there’s no support for these devices.

The first beta of Yalu102 only supported a handful of devices. However, Luca worked relentlessly to add offsets and make other devices compatible with Yalu102. This made iPhone 6s, iPhone 6, iPhone 5s, iPhone SE, iPod Touch 6G, iPad Pro and iPad mini fully compatible.

What next for the jailbreak community?

The latest beta 7 version supports all of the 64-bit devices except iPhone 7/7+.

cydia ios 10.2

Remember, iPhone 7 and iPhone 7 plus devices are only jailbreak-able on iOS 10.1 and 10.1.1.

  • If you have updated to iOS 10.2 without saving SHSH2 blobs, you will not be able to jailbreak.
  • If you iPhone 7/7+ is still on iOS 10./10.1.1, you can jailbreak it using Yalu beta 3. Follow our step by step tutorial here.

Don’t forget to like and follow us on Facebook and Twitter.

Leave a Reply