How to Fix “Depends iOS Firmware >=10.0” Cydia Error

Developer Jay Freeman has been regularly updating Cydia for iOS 10. The latest version offers improved stability and performance for iOS 10. However, this doesn’t stop users from experiencing the occasional Cydia error.

Today we will be learning how to fix the Depends iOS Firmware >=10.0 Cydia error on Yalu jailbreak. Since many users were reporting this error, I decided to create a proper tutorial for fixing it once and for all.

Here’s what this error looks like.

depends ios firmware 10

Fix “Depends iOS Firmware >=10.0” Cydia Error [TUTORIAL]

Step 1 Open Filza File Manager on your iOS device.

Step 2 Navigate to this location – /var/lib/dpkg.

Step 3 Open the status file. (Make a backup)

tweak status file

Step 4 Look for Packages: firmware.

Step 5 Change the firmware Version to the iOS version of your device. In the example shown above, you would need to change 9.3.2 to your current firmware version that is 10.1.1 or 10.2.

Step 6 Respring.

Cydia is finally stable and compatible with iOS 10 but the tweaks can somehow wreck your device. The only way to stay safe is to install them one by one.

If you face any other error, please follow our Troubleshoot Guide. Here are some other tweaks and tutorials you might find interesting –

If you liked this tutorial, share it on Facebook and Twitter.

20 Comments

  1. Trevor November 20, 2017
    • iOS Expert November 21, 2017
  2. OG Reilly Aidan May 7, 2017

Leave a Reply

Share3
Tweet